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License
ANTEVS is Copyright © 2011-2016 Frederick W. Vollmer. This program is distributed in the hope that
it will be useful, but without any warranty; without even the implied warranty of merchantability or 
fitness for a particular purpose. 

ANTEVS is free software, however you may not redistribute or post it online without the author's 
permission. It may only be distributed as the released compressed file package with this file and other 
included files. Any significant usage, such as a resulting presentation or publication, should include the 
following two attributions to the program and author:

Rayburn, J.A., and Vollmer, F.W., 2013. ANTEVS: A quantitative varve sequence cross-correlation 
technique with examples from the northeastern United States. GFF: Journal of the Geological 
Society of Sweden, v. 135, p 282-292.

Vollmer, F.W., 2016. ANTEVS 1.3.6: Automated Numerical Time-series Evaluation of Varying 
Sequences software. Retrieved from: www.frederickvollmer.com/antevs.

Any reference to the content of the User Manual (this document) may be cited as follows:

Vollmer, F.W., 2016. ANTEVS 1.3.6: Automated Numerical Time-series Evaluation of Varying 
Sequences software user manual. Retrieved from: www.frederickvollmer.com/antevs.

Installation
On Macintosh OS X, double click the disk image file (.dmg), and drag the Antevs application to your 
Applications folder, or other desired location. 

On Windows, unzip the zip file (.zip) using the Extract All option, and drag the Antevs application to 
any desired location.  

On Linux unpack the gzip file (.tgz), and copy the Antevs application to any desired location. 

The Example Data folder contains example files which are referred to in subsequent chapters.

http://www.frederickvollmer.com/antevs
http://www.frederickvollmer.com/antevs
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1. Introduction
Time-series arise in situations where a value is measured through time, generally at discrete 
intervals. Annual intervals commonly occur in natural systems due to seasonal variations in 
temperature, as displayed in proglacial varves, tree-rings, and glacial ice. Antevs (Automated 
Numerical Time-series Evaluation of Varying Sequences) is designed primarily to work with 
such natural time-series, but can be applied to other discrete time-series as well. Antevs is 
designed to aid in correlation of time-series, where an undated times-series, the unknown, is 
compared to a previously dated series, a chronology, to determine if they overlap in time and to 
date the unknown series.

Antevs was developed for the correlation of proglacial varve sequences (Rayburn and Vollmer, 
2013), however it includes standard techniques for matching tree-ring sequences, and can 
convert files between varve and tree-ring formats. It includes routines for reading the Velmex 
UniSlide digital readout used for tree-ring measurements. A common problem with natural time-
series is that of missing data, often due to broken cores. Antevs includes interactive procedures to
correlate sequences, such as broken cores, that contain missing values.

Antevs is designed to be user friendly and easy to use, with powerful analytical tools under the 
hood. It undergoes extensive testing by faculty and undergraduates working on research projects 
in John Rayburn's varve and tree-ring laboratory at the State University of New York at New 
Paltz.

Antevs is developed on Macintosh OS X and is compiled for Macintosh OS X, Windows, and 
Linux. Currently testing is done on OS X 10.6, 10.10, Windows XP, Windows 7, and Linux 
Ubuntu. User input is appreciated to improve operation on various platforms.
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2. Example Usage
To test the correlation of glacial varve series from the Hudson Valley at Newburgh, NY with the 
Connecticut Valley at Hartford, CT, download the following North American Varve Chronology 
(NAVC) Normal Curves files from the North American Glacial Varve Project website (data from 
Antevs, 1922; Ridge et al., 2012; Ridge, 2012): 

HUD29-32AM.txt
CON28-32AM.txt

or open the included TSV (Tab-Separated Value) files:

HUD29-32AM.tsv
CON28-32AM.tsv

Assume one is known and the other is unknown, so open HUD29-32AM as an unknown and 
CON28-32AM as a chronology (Figure 1). Select them both, and use the command Analyze > 
Data Plot to view the raw data (Figure 2). Note that the differences in scaling and long 
wavelength trends makes any correlation difficult to see.

2

Figure 1. Antevs Data Sets window with an unknown and a chronology file open and selected.
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To detrend and rescale the data select Analyze > Detrend to open the Preferences Dialog, and set
Detrend on, with a 16 term Fourier curve fit, using the Standardized normalization method 
(Figure 3). In the View Pane check Detrended data for both Unknown and Chronology (Figure
4), and press OK.

3

Figure 2. Data Graph window showing the two raw varve example data sets. The 
difference in scaling and the long term variations make the correlation difficult to 
see.

Figure 3. Preference Dialog > Detrend Pane with 
Detrend on, and default Fourier settings.
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The data plot will update to show the data detrended by removing long wavelength trends using a
16 term Fourier curve, and normalizing using standard deviations of the residuals, making the 
correlation more clear (Figure 5). To perform a cross-correlation and view the resulting 
correlogram, select Analyze > Correlogram (Figure 6). Use the mouse to examine the r 
correlation values. Note the strong spike at offset 0 and r = 0.643, the best correlation. 

4

Figure 4. Preferences Dialog > View Pane with Raw 
data and Detended data checked on for display.

Figure 5. Data graphs of raw and detrended data using a 16 term
Fourier series.
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Finally, select Analyze > Bin Test to see how subsets of the unknown match the known 
chronology. The default bin size is 50, with a minimum overlap of 50. Most of the subsets match 
with zero offset suggesting a robust match. 

Tests on NAVC varve data sets known to be correlated suggest that a correlogram with a single 
correlation spike with r >= 0.6 and z >= 6 is a good potential correlation for varves (Rayburn and
Vollmer, 2013). However, definitive correlation acceptance criteria are difficult to quantify, 
rather, Antevs provides statistical and graphical tools for the evaluation of sequences, 

5

Figure 6. Correlogram for two varve sequences showing a strong correlation 
spike at the best matching year with r = 0.643, z = 6.516.

Figure 7. Bin correlogram for varve data suggesting a robust fit at 0 year offset.
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recognizing that the ultimate decision for correlation, whether tree-rings, varves, or other time 
series, lies with the researcher (Grissino-Mayer, 2001; Rayburn and Vollmer, 2013).

6
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3. Data Entry
Antevs can read numerous data file formats, including most common spreadsheet files (e.g., 
Excel, LibreOffice) as described in Section 3.1. A header row in these files is used to describe 
the following data. Additionally, data can be entered directly using the Data Edit Window. A third
option is to use automated data collection with the Velmex Unislide digital readout system, 
commonly used for tree-ring measurements. 

3.1 Data Files

Numerous data file formats are supported, the simplest are spreadsheet (e.g., Excel, LibreOffice) 
compatible lists with a header. The default is a simple tab-separated value (TSV), or tab 
delimited, format for data, consisting of optional comment lines, a header identifying the data 
columns, and rows of data. For example:

// Hudson Valley; Newburgh; NY
// This is a comment
//
Year<tab>Raw<tab>Comment 
2900<tab>44.300<tab>
2901<tab>25.500<tab>approximate value only

Headers can include: ID, Year, Raw, Fit, Detrend, Count, and Mean. Count and Mean are special 
output headers used when creating a mean chronology. Summer, Winter, Comment (or Note) 
headers are also read and written, but are not otherwise used. It is best to avoid commas in 
comment lines. The TSV file format is recommended over the space-delimited TXT format, as it 
are can be read and written by most spreadsheet programs, and the comment and header lines 
provide self-documentation of the content.

A comma-separated value (CSV) format is identical to the TSV format, but uses commas as data 
delimiters. Note that commas in data fields can potentially cause problems. This format can be 
also read and written by most spreadsheet programs, for example:

// Hudson Valley; Newburgh; NY
// This is a comment
//
Year,Raw,Comment 
2900,44.300,
2901,25.500,approximate value only

A space-delimited format (TXT), which is for a single sample and has year or sequence number 
(first column), and total thickness as decimal values in centimeters in the second column. If four 
columns are detected they are assumed to be year, summer thickness, winter thickness, total 
thickness. A TSV format is recommended over this format.

7
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Three additional formats used by spreadsheet programs such as LibreOffice Calc and Microsoft 
Excel are supported: OpenDocument (ODS), Office Open XML (XLSX), and Excel (XLS) 
spreadsheet formats. The spreadsheet may have comments at the beginning starting with “//”, and
must have a header line as described above. 

3.2 Tree-Ring Files

A number of specialized formats have been developed for tree-ring files, some of which were 
based on Fortran punch card formats. Antevs can read and write a number of these, and convert 
them into other formats.

A Tucson decadal tree-ring raw measurement format (RWL) contains fixed column records with 
core id, decade or start year, and thicknesses. Multiple cores per file are supported. Thicknesses 
are stored as six digit integers in units of 0.01 mm or 0.001 mm. When opening a RWL file the 
precision is determined by the data stop values stored in the file. The desired output format can 
be set with the RWL units setting in the Preferences dialog (default is 0.001 mm). 

A Tucson tree-ring chronology format (CRN) contains a single composite mean chronology 
which is detrended and has a mean value of 1. To compare a raw unknown measurement to a 
CRN chronology, the Ratio method should be used for the unknown, as the Standardized method
gives a mean of 0. Note that a CRN chronology, as well as a Mean Master chronology (Section 
4.3), are not detrended or filtered as this is done when creating the mean chronology. The 
Detrend and Apply normalize filters settings are therefore ignored for mean chronologies.

3.3 Manual Data Entry

While it is often convenient enter data into a spreadsheet such as Excel or LibreOffice, entering a
new time series directly into Antevs is straightforward. In the main Data Sets window select the 
Unknowns grid, and then the File > New command. A new time series entitled “untitled” will be 
created (Figure 8). Change the title as required, and use the Edit Data command (pencil and 
paper icon) to open the Data Edit window (Figure 9). 

8
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By default the first year is 1900, edit the starting year as required (this can also be changed later),
and then begin entering data in the Raw column. Each entry advances the year by one and moves
the cursor down one row (Figure 10).

After data has been entered, the Cancel Edits (red X icon) and Accept Edits (green checkmark 
icon) commands become available. Use Accept Edits to accept the data, this will update any 

9

Figure 8. The Data Series Window after using the File > New 
command to create a new series. The series can be renamed as 
required.

Figure 9. The Data Edit Window after creating a new series. The start year is 
given a default value of 1900, edit this as required.
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currently open plots. Cancel Edits will revert the data to the previous state last accepted. The 
Revert command (blue curved arrow icon) is not currently available because the initial data 
series was empty. When editing a data set opened from a file, Revert will revert to the state when
the file was opened. When finished, accept the edits, close the Edit Data Window, and save the 
series from the Data Sets Window using the Save As command.

Antevs can be used for editing existing time series, and has additional commands such as for 
splitting and joining rows. If the time series start year must be changed, enter the new value in 
row 1, and use the Edit > Renumber command. Missing values (Section 5) are entered by “NaN”
(or “nan”), or, by default, any negative number.

3.4 Automated Data Entry

Antevs allows automated data collection using the Velmex Unislide digital readout system, 
commonly used for tree-ring measurements. This has been tested on Windows and Macintosh 
systems. To collect data measurements, click on the Unknown Grid list and use the File > New 
command to create a new file (Figure 8). Select the file, rename it as desired, and select Edit > 
Edit Data. In the Data Edit window (Figure 9), select Edit > Connect (blue plug and socket icon) 
and enter the required serial port parameters. 

3.4.1 Serial Port Connection

The Velmex Unislide digital readout system communicates via a serial port (RS-232 DB9), 
which requires a serial-to-USB converter on most computers. Numerous serial-to-USB 
converters are available, and their setups differ. Antevs is set for the default parameters that work
in our laboratory on Windows (COM3, 9600 baud, 8 data bits, 2 stop bits, no party, no flow 
control). On a Macintosh open the Terminal from the Applications Utilities folder, and enter the 
following command:

10

Figure 10. Manual entry of data in the Data Edit window, ready to enter data for
the year 1883. Grayed entries can not be edited. The Cancel Edits and Accept 
Edits icons are now enabled. 
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ls /dev/tty.*

This will list available serial ports. For the Macintosh using a Prolific PL2303 chip set serial 
USB converter the required port is:

/dev/tty.usbserial

This port works in our laboratory (Figure 11). An open source driver is available for the PL2303 
chip set that works on Macintosh, and is included on the Linux Ubuntu distribution. A free 
downloadable version from Prolific includes an installation manual (find it using a web search on
Prolific PL2303). 

Future versions of Antevs will attempt to connect with other data collection devices. The author 
will work with researchers who are attempting to automate their data collection, currently this 
must be through a serial port connection. 

3.4.2 Data Coordinate Entry

After connecting to the recording device in the Data Edit Window using the Edit > Connect (blue 
plug and socket icon) command, the Connect icon indicates a connection has been made, the 
Record icon (red circle) has changed from gray to red, and the status has changed from 
Disconnected to Connected (Figure 12). Antevs has four modes during automated data entry: 
Disconnected, Connected, Initializing, and Recording. These are indicated in the status bar, as 
well as by the color of the Record icon (gray, red, yellow, and green respectively). Each mode 
change is indicated by an audio cue, a click. User instructions are also given in the status bar.

11

Figure 11. Serial port dialog showing 
settings for a Macintosh computer, 
these may differ on your configuration.
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Edit the initial year as required (this can be changed later), and click on the red Record icon to 
initialize the device. The mode will change from Connected to Initializing, and the Record icon 
becomes orange (Figure 13).

12

Figure 12. The Data Edit window in Connected mode, after connection with 
the recording device. The Connect icon (blue plug and socket) indicates 
connection, the Record icon (red circle) has changed from gray to red, and the
status has changed from  Disconnected to Connected.

Figure 13. The Data Edit window in Initializing mode, ready to accept the 
coordinate of the start of the data sequence.
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Once in Initializing mode, position the recording device at the beginning of the data sequence, in 
this case at the start of the year 1900. The device should be reset to zero at this point, although 
this is not critical. When ready, use the device to send the coordinates, this will change the mode 
to Recording (Figure 14).

Once in recording mode, advance the recording device to the end of the first year, in this case the
end of 1900, and send the coordinates from the device. The measurement for the first year is now
displayed, and Antevs is ready to accept the coordinate for the next year, in this case 1901 
(Figure 15).

The Cancel Edits (red X icon) and Accept Edits (green checkmark icon) commands are now 
available. Use Accept Edits to accept the data, this will update any currently open plots. Cancel 
Edits will revert the data to the previous state last accepted. The Revert command (blue curved 
arrow icon) is not currently available because the initial data series was empty. When editing a 
data set opened from a file, Revert will revert to the state when the file was opened. 

13

Figure 14. The Data Edit Window in Recording mode, ready to record a data 
series.
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Advance the device to the end of the next year, here 1901, and send the coordinates. Continue 
with subsequent years until data collection is complete. Antevs gives an audio cue, a beep, when 
a decade entry, divisible by 10, is made. Data entry may be paused by selecting Record, and 
continued by reinitializing the beginning of the next year to be entered (the end of the last year 
entered). When finished, use Accept Edits (Figure 16), then Save As in the Data Series Window 
to save to disk.

14

Figure 15. The Data Edit Window in Recording mode after the first 
measurement, here for the year 1900.

Figure 16. The Data Edit Window after entering a time series, and using the 
Accept Edits command (green checkmark icon, now gray).
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4. Time-Series Analysis
Time-series arise in situations where a value is measured through time, generally at discrete 
intervals. In natural systems annual intervals commonly occur due to seasonal variations in 
temperature, as seen in proglacial varves, tree-rings, and glacial ice. Antevs is designed primarily
to work with such natural time-series, but can be applied to other discrete time-series as well. 
Antevs is designed to aid in correlation of time-series, where an undated times-series, the 
unknown, is compared to a previously dated series, a chronology, to determine if they overlap in 
time and to date the unknown series.

The analysis in Antevs is broken down into three main parts. Detrending is done to remove 
longer term trends or wavelengths, and to rescale the time-series so they can be more easily 
compared. A curve is fit to the time-series, and the fitted curve is removed from the data values.  
Filtering may optionally be done following detrending, and can potentially enhance correlations 
by using neighboring values to smooth local values. Finally, the two time-series are cross-
correlated to determine if a match can be found between them.

Data plots can be used to visually compare the raw or detrended series, and a correlogram allows
visual evaluation of the cross-correlation. Additionally, a bin test can be done to test the 
robustness of the match. Finally, a group of correlated series can be used to create a mean series, 
to serve as a master chronology.

4.1 Detrend

Detrending rescales the raw data and removes longer wavelength trends by fitting a curve to the 
data set, and adjusting the raw data values using the fitted values. This allows sequences with 
different environmental inputs to be more easily correlated, such as distal and proximal varves, 
or young and old tree-ring growth. The residuals are the data values minus the fitted values:

ri = yi - ŷi  

where ŷi is the estimate calculated by fitting a curve or function to the data.

4.1.1 Mean 

Fits to the mean of y:

ŷi = Σ yi / n

4.1.2 Linear 

Fits a linear curve:

ŷ = a + bx

by minimizing the squared residuals in y.

15
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4.1.3 Quadratic

Fits a quadratic curve:

ŷ = a  + bx + cx2

by minimizing the squared residuals in y.

4.1.4 Cubic

Fits a cubic curve:

ŷ = a + bx + cx2 + dx3

by minimizing the squared residuals in y.

4.1.5 Exponential

Fits an exponential curve:

ŷ = aebx + c

to the data by minimizing the squared residuals in y using an iterative method. This can be useful
for tree-rings that have a regular decrease in width with age, but can fail in many cases.

4.1.6 Automatic

For cubic, quadratic and linear curve fitting a fit is rejected if a negative thickness is predicted, 
and a lower order curve is tried, until the mean is used. For an exponential fit, the curve is 
rejected with b > 0 or c < 0, and a linear curve fit is tried. If a linear fit is rejected with b > 0, or a
negative thickness is predicted, the data is fits to the mean value of y. Automatic exponential is a 
common choice for some tree-ring data sets (Cook and Holmes, 1986).

4.1.7 Spline

Fits a cubic spline to the raw data. The Stiffness parameter controls the tightness of the curve 
(Cook and Peters, 1981). 

4.1.8 Fourier

Fits a Fourier series to the raw data. The Low pass frequencies parameter controls the number of
components in the series. This is the default method used for varve analysis, with a default 
setting of 16 (Rayburn and Vollmer, 2013).

16



ANTEVS User Manual

4.1.9 Method

The Detrend Method sets the method by which the fit curve is used to detrend the raw data. 
Common settings are Standardized and Ratio, both of which give unitless values. The 
Standardized is the default setting, and is recommended unless Ratio is required for 
compatibility with other files or workers.

4.1.9.1 Fit

Displays the fit curve, ŷi.

4.1.9.2 Residual

The residual method uses the residuals, subtracting the predicted value, ŷi , from the data value, 
yi: 

ri = (yi – ŷi)

These are not normalized, so units are in centimeters or millimeters, with a mean of zero.

4.1.9.3 Standardized

Standardizes, or normalizes, the residuals by dividing by the standard deviation of residuals. The 
data is transformed to standard deviations from the fit curve. 

y' = (yi - ŷi) / σ

Where σ is the standard deviation. This allows comparison of differing series, as it gives 
unitless numbers with a mean of zero. This is the default method for varve analysis.

4.1.9.4 Ratio

Uses the ratio method:

y' = (yi / ŷi)

The ratio method is commonly used for tree-ring data. It can be biased however, and using 
residuals (standardized method) is more robust. Values of ŷi near zero must be discarded to avoid
divide by zero errors. The mean of the detrended values will be 1.

4.1.9.5 Ratio log

Uses the Ratio method (Section 4.1.9.4) and applies a log transform for variance stabilization 
after adding a constant of one-sixth of the series mean to each value.

17
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4.2 Filter

Displays the filters dialog. Filters are applied after detrending the data to normalize the data and 
potentially emphasize correlations. Normalizing involves smoothing the data by using 
neighboring values. 

4.2.1 Delta bar

Smooths using the average of the nearest neighboring data points:

yi' = (yi-1 + yi + yi+1) / 3

Rayburn and Vollmer (2013) suggest this filter may help emphasize some varve correlations.

4.2.2 Cubic derivative

Orthogonal cubic first derivative filter. Smooths using the cubic derivative of the nearest 
neighboring data points. This filters the data to look for changes in slope of the series using the 
first derivative of a local cubic polynomial. The number of terms can be 5, 7, or 9. The 5 term 
cubic derivative filter can be particularly effective for correlation.

4.2.3 Ratio

Smooths using the ratio of current and previous years: 

yi' = (yi / yi-1)

4.2.4 Natural

Logarithmic, or natural, change from previous year to current year (Hollstein): 

yi' = Log(yi / yi-1)

4.2.5 Relative

Relative change from previous to current year: 

yi' = (yi - yi-1) / yi-1

4.2.6 Log five year

Five year natural logarithmic smoothing filter (Baillie and Pilcher, 1973): 

yi' = Log(5 * xi
2) / (xi-2 + xi-1 + xi + xi+1 + xi+2))

4.3 Mean Master

Calculates a mean master series of all open data series, either chronologies or unknowns. Each 
series is detrended before calculating the mean. Before creating a mean master series,  the 

18
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Detrend option should be checked in the Preferences > Detrend Panel, and either Standardized 
(recommended) or Ratio methods selected. Detrending rescales the series so each is weighted 
equally. The data series are not normalized when calculating the mean, so the normalize filter 
setting does not matter. 

Note that detrending using the Standardized method gives values with a mean of zero, and 
therefore will create negative values. The Treat negative as missing and Display missing as “-9” 
options (see Section 5) must be off. The Ratio method gives values with a mean of 1, it is less 
robust, and only recommend if it is required for compatibility, such as when using a Tucson CRN
tree-ring mean chronology.

When using either a mean master chronology, or a Tucson CRN tree-ring mean chronology to 
correlate an unknown raw time-series, the mean chronologies are not detrended or filtered as 
detrended was already done when creating the mean chronology. The Detrend and Apply 
normalize filters settings are therefore ignored for mean chronologies.

4.4 Data Plot

The Data Plot plots unknown and chronology thickness, or normalized thicknesses, versus year. 
It optionally plots best fit curves and raw data for unknowns and chronologies. This plot can be 
zoomed for a closer view of the data (Chapter 5), and can be used to segment the time-series if 
there are gaps or missing data (Chapter 6).

4.5 Cross-Correlation

Applies the current filters, first detrending then normalizing, and calculates the cross-correlations
and t statistics for each possible match. The default overlap required for a test is 50, this can be 
changed in the Preference Dialog > Limits Panel.

4.6 Bin Test

Sequentially groups the unknown data into bins, similar to bootstrapping, and runs each against 
the selected chronology displaying the best correlations based on the t statistic. Used to test the 
robustness of the match and to potentially locate missing varves or tree-rings in an unknown. The
bin size can be changed in the Preference Dialog > Limits Panel. The bin size must be larger or 
equal to than the minimum overlap.

19
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5. Data Windowing
The Data Plot can be zoomed in to examine a portion of the time-series allowing more detailed 
examination. The Zoom Data Window command (green square icon) zooms in on a segment of 
the time-series, the length of the segment is set in the Preferences > Limits pane using the Data 
window width setting. Use the Pan Left, Pan Right, Pan First, and Pan Last commands in the 
View menu to move the window. The step size can be set in the Preferences > Limits pane using 
the Data window step setting. The Full Data Window command restores the full time-series 
window.

The Pan Left and Pan Right icons (green arrow icons) also pan the data window, and holding 
down the Shift key changes these to Pan First and Pan Last. Additionally, the bracket keys (“[“ 
and “]”) are provided as shortcut keys for Pan Left and Pan Right.

20
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6. Segments and Missing Data
A common problem in natural data sets such as varves and tree-rings is missing data points, as 
cores or observable varve sequences can be broken or discontinuous. Antevs treats missing data 
points as NaN (Not a Number) values, which have no numeric value. There can be any number 
of NaN data points in a sequence. In order to deal with this internally and avoid numerical errors,
Antevs uses linear interpolation over the NaN values. This is, for example, the default used by 
MatLab to deal with NaN values in numerical analysis.

Breaks can be inserted into the unknown time-series, allowing individual segments of an 
unknown time-series to be interactively shifted in time by incrementing or decrementing them. 
The segments can be individually compared to the chronology, and slid forward or backwards to 
match. Additionally, the cross-correlation can be automatically calculated at each step to test the 
strength of the match.

6.1 Missing Values

Antevs treats missing data points as NaN (Not a Number) values, which have no numeric value, 
and there can be any number of NaN data points in a sequence. In order to deal with this 
internally and avoid numerical errors, Antevs uses linear interpolation over the NaN values. This 
is, for example, the default used by MatLab to deal with NaN values in numerical analysis.

To maintain operability with time series that may contain negative values (such as temperature), 
Antevs currently has two settings to control how it deals with NaN values. These are set in the 
Preferences > Options panel. If Treat negative as missing is checked (by default it is not), any 
negative number is treated as a NaN. The second option, Display missing as “-9”,  controls how 
the NaN is displayed in the Data Edit Window and output files. This is also off by default, 
however, a common convention in tree-ring data is to use “-9” to signify a missing value. If that 
is important, turn this option on, and “-9” will be displayed instead of “NaN” in the Data Edit 
window, and in saved files. Note, however, that treating negative values as NaN will create 
problems when creating a mean series using standardized detrending. Standardized detrending 
produces a series with a mean of zero, and will contain negative values.  

Figure 17 shows a simple example of a time series with NaN values, and Figure 18 shows the 
Data Plot of this series. The three NaN values between 1901 and 1905 are interpolated. NaN 
values van be entered in the Data Edit window, or in input files, as “NaN” (or “nan”), or, if Treat 
negative as missing is checked, any negative number.
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6.2 Segmented Series

A common problem in natural time-series is missing data, caused, for example, by broken or 
incomplete cores. As described in Section 6.1 Missing Values, Antevs allows inserting NaN 
values to break a series into individual segments, however inserting NaN values manually can be 
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Figure 17. Simple example of a time series with NaN 
values. The NaN values between 1901 and 1905 are 
interpolated.

Figure 18. Data Graph of the time series in Figure 17.
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cumbersome. Antevs therefore provides a more interactive segment editing mode. The series can 
be broken up into any number of segments, and the segments can be shifted in time to locate a 
better match.

To begin segment analysis, open a time-series as an unknown. Segment analysis can only be 
done on one unknown time-series at a time, this will be the first unknown series selected if 
multiple unknowns are selected. Next select the Edit > Edit Segments command in the Data Plot 
window to put Antevs in segment edit mode. All data points will be marked with a white circle. 
To begin editing, click on the symbol of the data point at the start or end of a segment that you 
wish to shift. The segment start point will then be marked with a red circle. Shifting the point to 
the right (to decrease its age) or left (to increase its age) will create a break by inserting a NaN 
data point, which is marked by a small red circle. Once a segment is created, the segment 
endpoint will be marked with a yellow circle. The symbols are displayed in the Raw, Detrended, 
and Filtered curves, any of these can be used for editing. The default symbols can be changed in 
the Preferences dialog. 

To shift a segment, use the Increment Segment and Decrement Segment commands. The Right 
arrow and Left arrow keys are shortcuts, and holding down the Shift key will increment or 
decrement by 10. Moving one segment will insert or remove NaN data points and shift the 
segment. For example, if there are three segments, 1, 2 and, 3 from left to right, shifting segment 
2 to the right will add NaNs to its left, and remove them to its right. Once all NaNs to the right 
are removed, segments 2 is joined to segment 3. Selecting the first or last point in the series will 
shift the entire series.
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Mistakenly reversed segments may occur during data collection, for example during the 
collection of broken cores. The Reverse Segment command may be used to reverse an 
individual segment to look for a match.

If open, the Correlogram window will update and show the correlation values. Use the Accept 
Edits command to accept the edited values. The Cancel Edits command will revert to the state 
when Accept Edits was last called. The Revert command reverts to the state on opening the file.

Note that the ID field is used to give each entry a unique identification number. When shifting 
segments new data points are added as NaN values, and these will be given the next available 
highest ID. The ID can be any integer value, such as the initially estimated year sequence, or a 
series starting with 0 or 1. When reading in a data file, Antevs will assign an ID value if one is 
missing. This allows the Year field to be modified, as the ID is not modified when renumbering 
or inserting missing values. When deleting, splitting,  or combining rows, or editing segments, 
the next available unique ID number is assigned. The Set ID from Year command in the Data Edit
window will set the ID field to the Year if desired.
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Figure 19. Data Plot window with a segmented unknown (red 367101) compared to an identical 
chronology (blue 36701). The unknown has two segments, the second, starting at 1721, as indicated by 
the red circle , has a one year offset from its original start position at 1720. A NaN value has been inserted
at 1720, as indicated by the small red dot.
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8. History
1.3.6.4 (2016-12-03)
• Fixed and improved segment editing. Now segments can be slid forwards and backwards, and

individual segments move independently.
• Now displays years in short segments without decimal points
• Fixed delete selected year in series editing window, was deleting the last year instead of 

selected year.
• Fixed a divide by zero bug that occurred during the display of a series with two data points.
• Fixed About box display.

1.3.5.5 (2016-11-21)
• Changed messaging procedures from PostMessage to Dispatch message.
• Fixed metadata editing in spreadsheet file formats.
• Fixed initial year assignment bug.
• Added Home Page command.
• Added automatic version checking, and Check for Updates command.
• Updated grids.
• Segment editing entirely replaced, see Section 6.2.
• Graph Window renamed Plot Window.

1.3.4.1 (2016-04-27)
• Fixed display of segments when reopening file saved with NaN values.

1.3.3.7 (2016-04-03)
• Now automatically renumbers when inserting a NaN during graphical editing.
• Saves and reads three lines of metadata in Tucson decadal crn files.
• Now correctly reads Tucson decadal rwl files with negative years.
• New command Edit Metadata to edit metadata.
• After data is entered in the Data Edit window with the Vemlex recording device, the window 

can now be closed without the Accept Edits warning.
• Edit New now allows more than one “untitled” files.
• In file window mouse Shift-Click selection now selects a block of rows. Command-Click 

(Control-Click) toggles one row as previously.
• Fixed status display in the Graph window.
• Removed the confusing Break Segment command. Now, in Edit Segments mode clicking 

inside a segment cuts it (click again to undo), and clicking on the start of a segment selects it. 
See Section 6.2.

1.3.2.4 (2016-02-22)
• Bound resource files into executable for Windows and Linux.
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• Added back Zoom Data toolbar pan buttons, press Shift to pan to first or last year.
• Added saving of comments to mean master file.
• Added Encapsulated Postscript and DXF vector export.
• Consolidated graphics output to Export Image commands.
• Added Page Size command for Data Graph and Correlograms.
• Work on User Manual, including Chapter 8 to clarify Data Windowing.
• Removed “Unknown” and “Chronology” from Data Graph legend.
• Compiled with LCL 1.6.0 and FPC 3.0.0 optimizations.
• Fixed 999 bug in RWL writing.

1.3.1.14 (2016-02-13)
• Optimized data grid scrolling.
• Optimized messaging.
• Remembers last data file directory.
• Fixed index range bug in splines.
• Data plots now update during editing in Data Window.
• Correlogram now correctly updates when no data list is selected, and when lists are opened or 

closed.
• The edited state can now be saved by the Accept Edits command either during editing in the 

data window, or during editing using the Edit Segments command in the plot window. The 
Cancel Edits command restores to that state. 

• Removed Refresh toolbar button, Auto-Refresh is on by default.
• Removed Zoom Window pan toolbar buttons from Plot Window, the Cmd-[ (Pan Left) and 

Cmd-] (Pan Right) and Shift Cmd-[ (Pan First) and Shift Cmd-] (Pan Last) keys are now 
enabled for this.

• Added automatic renumbering for edit operations. This already occurs for segment editing.
• Added automatic ID assignment for editing. The ID is always a unique number.
• If no IDs are input a sequential value starting at 1 will be assigned.
• Added ability to change plot frame color, default is now black with while background.
• Added additional icon sizes for Windows 7 and up.
• Added Reverse Segment command.
• Cleaned up some dialog control display issues. 
• Now reads rwl files containing non-standard LFLF sequences output by some software.
• The rwl file units  are now correctly set during reading by checking for stop markers “999” 

(0.01 mm) or “-9999”  (0.001 mm) in file (Cybis Wiki contributors, 2015). Note “999” stop 
marker disallows 9.99 mm rings in 0.01 mm files. 

• Changes to 0.001 mm rwl file reading and writing following D. Barclay (per J. Rayburn). 
Writing uses “-9” instead of “0”. Reading treats any negative value as missing, not “0”. See 
Cybis Wiki contributors (2015) for “0” convention. 

• Changes to reading and writing missing values in 0.01 mm rwl files following Cybis Wiki 
contributors (2015). Writing uses “-999”. Reading treats any negative value as missing.

• Added reading of rwl meta-data headers.
• Added writing of meta-data headers.
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1.3.0.3 (2015-06-29)
• Serial Settings, Initialize Read, Split,  and Preferences dialogs re-configured for better cross-

platform consistency. Additional tooltip help added. TLabel controls replaced with 
TStaticText.

• Added “ID” column to provide a unique identifier for each measurement to allow editing of 
years without losing track of initial input values. See Section 5. Feature request by Andrew 
Breckenridge.

• Added command to set the ID from the Year. This will change the ID to the current year, and 
would normally only be done during initial measurements.

• Fixed the reading of spreadsheet files (ods, xls, xlsx) so column order is not important. 
• Made “Ratio Log” a separate method option instead of using checkboxes, this uses the Ratio 

method followed by log normalization (COFECHA option). A combobox allows separate 
methods for unknowns and chronologies. 

• Numerous internal changes to preferences code for easier updates.
• Added visual segment editing for missing data and broken cores with 6 new segment analysis 

commands, see Section 5.  
• New icon. 

1.2.1.1 (2015-01-29)
• Made default for treat negative as NaN to false to avoid problems with mean series when 

using standardized detending.
• Fixed bug causing crash when renaming Chronology.
• Fixed widths in initial display of columns.
• Currently line count: 159,471.

1.2.0.13 (2015-01-07)
• Added StatusBars to MainWindow and DataWindow.
• Replaced Timers with Messages to communicate between windows.
• Replaced StringGrids with DrawGrids to avoid internal data duplication.
• Numerous internal changes for utilizing Messages and DrawGrids, resulting in more 

maintainable code for future updates. 
• Grayed uneditable cells in grids.
• Fixed LogForm to open in front when Preferences > Options > Display log is checked.
• Added date time string to LogForm, and added left margin.
• Added Unknown and Chronology dates to Correlogram status bar. The correlogram status bar 

now contains all information contained in the Log file.
• Fixed 'Save As' command to rename file in MainWindow grids.
• Changed 'Clear' to 'Close' in file close warning dialogs.
• Fixed the extra warning dialog when closing a file modified in the DataWindow.
• Modified to 'Revert' command. In the Data Window, Cancel Edits reverts to the last state 

saved with Accept Edits, while Revert returns to the state when the file was opened.
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• Numerous changes to Data Edit Window input procedures. Current mode and user 
instructions are provided in the status bar (instead of dialog boxes) to clarify. A default year is 
given (1900), which can be edited. Data may be entered manually or using the recorder. The 
modes: Disconnected, Connected, Initializing, and Recording are indicated in the status bar, 
as well as by the Record button (gray, red, yellow, green). Mode changes also have audible 
cues.

• Fixed Error Opening File dialog to display file name.
• Fixed an error that cleared the file list when opening a new ods, xls, or xlsx file.
• Updated the spreadsheet opening/saving component. Previously a file open in Excel or 

LibreOffice could not be opened simultaneously in Antevs due to file privileges. It is now 
possible to do so, however, with the risk of file version collision. Save the file in one program 
before opening it in the other.

• DataWindow tool hint "Insert Row" changed to "Insert Row Before".
• DataWindow Append button switched position with Insert.
• Changed default bin size from 100 to 50, and minimum overlap from 60 to 50.
• Added mouse-over status to Frequency Graph. This is an experimental graph, and its 

interpretation is not straight-forward. It is a periodogram, a modulus-squared of the Fourier 
transform.

• Added "Time" as input alias header for "Year", to accommodate monthly, hourly, etc., time 
series.

• Missing data is now supported, see Section 5.

1.1.0.3 (2014-10-04)
• Updated to minor version 1.
• Internal modifications to file save routines.
• Changed Edit > Clear command to File > Close, and added Cmd-W accelerator key.
• Changed Auto-Update default to true.
• Grids now save column widths between sessions.
• Moved Analyze > Refresh to View > Refresh, fixed disabled command when Auto-Update is 

off, changed accelerator key from Cmd-H to Cmd-R.
• Paint pickers updated to use opacity.
• Added ability to open Excel XLS and XLSX files.
• Fix to correctly save initial comment lines in File > Save As.
• Modified data collection routines to ask for initial date.
• Linux: Fixed image centering bug using work around.
• Linux: Fixed Preference dialog so visible pane always matches panel listbox selection.
• Expanded User Manual.

1.0.6.6 (2014-02-23)
• Numerous changes to the Data Edit Window to implement reading the Velmex UniSlide 

digital readout for logging tree-ring data. See section in ANTEVS User Manual on Data 
Collection.

• Implemented messaging to replace global flags and minimize recalculations.
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• Fixed and bug that was disallowing multiple open series for some formats.
• Added warnings for saving data.
• Disallowed opening series with identical names. 
• Fixes to File Save dialog.
• Added Save As command to Data Edit window.
• Changed the name from ANTEVS (Automatic Numerical Time-series Evaluation of Varve 

Sequences) to ANTEVS (Automated Numerical Time-series Evaluation of Varying 
Sequences).

1.0.5.9 (2013-04-29)
• Fixed Revert command in data edit window. This command reverts the data to the last time it 

was opened or saved.
• Added Select All command.
• Removed depreciated Clear All command, use Select All + Clear commands.
• Made Precision apply to displayed data as well as file output.
• Added ODS (OpenDocument), XLS, and XLSX spreadsheet formats to Save As command. 
• Added Export Sets command to save all selected data sets in one TSV, CSV, ODS, XLS, 

XLSX, or RWL (decadal) format file. See Brewer et al., 2011.
• Added ODS spreadsheet format to Open command.
• Open command now detects and opens TSV, CSV, ODS files, in addition to RWL format files,

to open multiple sets files created with Export Sets command. 

1.0.4.10 (2013-04-22)
• Grouped graph components in SVG output for easier editing.
• Fixed text vertical alignment in SVG output.
• Changed menu item Save As Vector Graphics to Export SVG.
• Removed Unicode => symbol, not recognized by AI Helvetica.
• Added target CPU and system info to About dialog box.
• Added comment editing.
• Added Split command to split, join and renumber data measurements.
• Removed depreciated Combine command.
• Preference file modifications.

1.0.3.7 (2013-04-08)
• Fixed floating point error caused if detrend curve exactly equals data.
• Fixed preference button hints.
• Allow opening of Preference dialog without selecting or opening data. 
• Added menu options to open Preference dialog Detrend and Filter pages.
• Added fit curve color selection.
• Added About dialog.
• Compiled with FPC 2.6.2, LCL 1.0.8.

1.0.2.5 (2013-04-01)

31



ANTEVS User Manual

• Fixed bug causing freeze when opening Precision dialog.
• Precision now stored in preference file.
• Precision settings moved to Preferences dialog.
• Added ANTEVS header to TXT files.
• Changed default file type to TSV (tab separated values).
• Modified Save As for TXT, TSV, CSV files to save Year and Raw columns only.
• Added z score, standard deviation, count,  and offset to cross-correlation graph.
• Changed precision to three places in cross-correlation display.
• Displayed maximum t value now always corresponds to maximum r value.
• Added p to t graph.
• Changed title of 'Filters' dialog box to 'Preferences'.
• Changed page selection in preference dialog to combobox.
• Detrend, Filters, and View preferences are now saved to preference file.
• Added option to turn off display of cross-correlation significance in Preferences Options tab.
• Added stroke selection for graph data.
• Fixed runs trend bug.

1.0.1.4 (2013-03-16)
• Compiled with Free Pascal 2.6.0 and Lazarus 1.0.6.
• Fixed missing tick marks bug. 
• Fixed tick marks stroke color.
• Fixed vector font export bug, fonts are now filled instead of stroked.
• Fixed incorrect log references.
• Fixed fill color bug in SVG export.

1.0.0.1 (2012-10-31)
• First official release for review.

0.0.20 (2012-09-18)
• Compiled with Free Pascal 2.6 and Lazarus 1.0.
• Fixed Save As command to save raw data instead of detrended data.
• Added new Save Detrend command saves detrended data.
• Added preliminary frequency spectrum (periodogram) graph, use Window > Frequency to 

view.

0.0.19 (2012-04-15)
• Added multiple colors to data graph.

0.0.18 (2012-04-08)
• Recompiled on Free Pascal 2.6.0.
• Added Spline detrending, following COFECHA. 
• Added Log transform for the Ratio method, following COFECHA.
• Added csv and tsv data files for both raw data and mean masters. 
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• Combined file formats into Open and Save As dialogs, and removed multiple Open and Save
As commands.

• Removed Delta bar past filter. 
• Added Link checkbox to link unknown and chronology detrend methods.
• Added max and mean labels to correlogram and bin graphs.
• TODO: Interpolate missing values.
• TODO: Debug RWL and CRN missing value and end data values, 999, -999, -9999, etc.

0.0.17 (2012-02-24)
• Added ability to select and view multiple data sets by control (Windows) or command (Mac) 

clicking. Note that only the first selected file in the unknown and chronology grids is used for 
most operations (cross correlation, saving files, etc.).

• Added data windowing with panning to allow detailed view and stepping through data.
• Added cross-correlation of data window.
• Added Count column in data edit grid, this gives data counts for means and CRN files.
• Fixed memory leak.
• Added Save As CRN Chronology for mean and CRN data series.  
• Enabled Preferences command on Mac (same as Filters).

0.0.16 (2012-02-05)
• Added Fourier detrending for variable terms. 
• Added two delta filters mainly for use with Standardize detrend method. These are more 

stable and handle zero thicknesses naturally (no division by zero). Note the Cubic derivative 
is also stable. Note that the common Ratio method normalize filters do not work well with the
Standardize detrend method, because the mean is zero instead of one.

• Added Delta bar filter: y1' = y1 - (y0+y1+y2)/3.
• Added Delta bar past filter: y3' = y3 - (y0+y1+y2)/3. 
• Removed Difference filter, this was identical to Delta bar past with 1 term.
• Removed polynomial smoothing detrending as not effective, was similar to Fourier with many

terms.
• Removed quadratic polynomial derivative filter as not effective, overly smoothed data.
• Added mean toolbutton.
• Added detrend Fit method, this gives the fit curve for display or saving to file. It is not useful 

for correlation.
• Stacked raw, detrend, and filtered data graphs.
• Numerous additional fixes.

0.0.15 (2012-02-19)
• Changed name to ANTEVS (Automated Numerical Time-series Evaluation of Varve 

Sequences), or Antevs.
• Added automatic option for detrending polynomial curve fitting. See Detrend above.
• Changed automatic exponential to reject linear fits that predict negative thicknesses. This 

removes some errors in detrending (e.g., calculating a mean for ny005.rwl, series 22).
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• Added orthogonal quadratic polynomial smoothing filters. See Normalize above.
• Added orthogonal quadratic and cubic polynomial first derivative filters. See Normalize 

above. 
• No longer saves window size when maximized.
• Added residuals and standard residuals detrend methods. See Detrend above.
• Added data series name edit.
• Made Filters dialog nonmodal.
• Added Detrended column to Data Edit grid.
• Enabled Quit command in Windows.

0.0.14 (2012-02-16)
• Fixed saving of mean files.
• Rewrote handling of zero thicknesses, only used during normalization to avoid division by 

zero or log zero. 
• Stacked graphs with scales on all curves.
• Fixed update of Data Edit grid when a chronology is viewed.
• Fixed update of main data set grid after editing data.
• Optional runs trend calculation is done simultaneously and viewed on a separate stacked 

graph.
• Runs trend algorithm is modified slightly following Corina; an up/down/same = 

up/down/same match gets +1, a same = up/down gets +0.5, otherwise no match gets 0.

0.0.13 (2012-02-06)
• Rewrote cross-correlation procedure to minimize potential round off, no change in 

functionality.
• Fixed bug in graph frame drawing.
• Fixed bug in exponential fitting, was not fully converging.
• Added y scale labels to data graph for raw data on right. Filtered data scale remains on left. 

Grid is drawn for filtered data unless only raw or detrend fit is on. 
• Fixed Clear tool button, was not working.
• Fixed two bugs causing random errors in mean calculation.
• Changed menu text from "Cross-Correlation" to "Correlation", no change in functionality.

0.0.12 (2012-02-05)
• Added Zoom commands and controls, including mouse dragging.
• Fixed Accept Edits command in Data Edit window, was not keeping edits.
• Changed Processed to Filtered for clarity.
• Changed Data View to Data Edit.
• Added toolbar to Data Set window.
• Added data names to graphs.
• Fixed y axis scaling error on data graph.
• Added correlogram caption.
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• Linked Filter Normalize controls, so changing unknown now changes chronology. Added an 
option to turn linking off, but there is no reason for these to differ. May combine in next 
version.

• Fixed Save As, was not enabled.
• Added more information in status bar.

0.0.11 (2012-01-28)
• Added graphics buffer to fix slow redraw on Windows. 
• Fixed focus loss when closing filters dialog on Windows.
• Fixed divide by zero error

0.0.10 (2012-01-28)
• Fixed window position xml preferences
• Fixed error reading rwl, 999 entries now excluded as well as -9999
• Fixed data view, was not updating on data grid focus change
• Enabled view detrend as always available
• Fixed error in mean calculation, was not detrending with correct settings
• Added save view options in preferences
• Fixed divide by zero error

0.0.9 (2012-01-25)
• Internal changes for easier maintanence
• Fixed compatibility with OS X 10.5

0.0.8 (2012-01-18)
• Added graph of offset values to bin test correlogram.
• Added color keys for curves on graphs.
• Restored ability to calculate mean chronology.
• Restored option to view log output.
• Fixed bugs in bin test.
• Made auto-refresh optional.
• Added Refresh command and toolbar buttons.
• Fixed label and grid spacings to auto-size.
• Added ability to open CRN files.
• Added ability to detect and  open four column TXT files.
• TXT file is checked for non-sequential values.
• Added Open command that uses file extension to determine file type.
• Added quadratic and cubic detrending options.
• Turned off automatic renumbering when editing a file.
• Added Renumber command.

0.0.7 (2012-01-08)
• Completed graphical display of bin test and data display.
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• Simplified analyze options.
• Depreciated log test display window.
• Added curve fitting and detrending algorithms.
• Implemented Marquardt non-linear curve fitting.
• Added best-fit curve display to data graph window.
• Redesignated growth correlations as normalize filters, e.g., Natural and Difference.
• Added additional normalize filters, e.g., Log five year and Two year sum.
• Depreciated cross-association (available in Filters Extra tab).
• Depreciated runs analysis (available in Filters Extra tab as SIgn).
• Experimental implementation of area correction algorithm (depreciated).
• Implemented chronology data display. 
• Implemented unknown data editing with preview and restore.
• Added minimum thickness value with default of 0.001.
• Added automatic update of Data View, Data Graph, Bin Test and Correlogram windows.
• Created new icon.
• Added preference file to remember window locations and sizes.
• Added vector graphics SVG output of graphs.
• Added PNG, BMG, and JPG bitmap output of graphs.

0.0.6 (2011-12-11)
• Added Graph Window.
• Added Thickness Graph.
• Added Growth Graph.
• Added year offsets to Log Window anaylses to assist in locating matches.

0.0.5 (2011-12-03)
• Added 'Precision' command to set precisions in files to avoid precision loss when converting 

varve to tree-ring format.
• Enabled Analyze and Window commands from Log Window.
• Added Mean Growth command.
• Added Growth Correlation command.
• Modified Bin Test to allow setting of additional filtering parameters, including multiple 

matches per bin. 
• Added desktop icon.

0.0.4 (2011-11-21)
• Rewrote Trend Percentage algorithm.

0.0.3 (2011-11-20)
• Added Normalize.
• Added Normalized Mean.
• Added Cross-Correlation.
• Added Runs Correlation.
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• Added Bin Test.
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